La Ferme du web - Les forums

Venez baraguiner avec la communauté !

Vous n'êtes pas identifié.

#1 21/09/2009 11:56:59

Hotfirenet
Membre
Date d'inscription: 21/09/2009
Messages: 9
Site web

Nouveau problème de vHosts

bonjour djo,
j'ai suivi ton tuto sur l'installation de apache2, mais lorsque je fais :
a2ensite hotfirenet.fr

j'ai le droit a cette erreur :

Code:

root [~] > a2ensite hotfirenet.fr
ERROR: Site hotfirenet.fr does not exist!

voici le contenu de mon fichier hotfirenet.fr :

Code:

root [~] > cat /etc/apache2/sites-enabled/hotfirenet.fr
<VirtualHost *>
        ServerAdmin hotfirenet@gmail.com
        ServerName www.hotfirenet.fr
        ServerAlias *.hotfirenet.fr
       # DocumentRoot /home/hotfirenet/sites/hotfirenet.fr/
        DocumentRoot /var/www/hotfirenet.fr/
       # <Directory /home/hotfirenet/sites/hotfirenet.fr/>
        <Directory /var/www/hotfirenet.fr/>
                Options -Indexes FollowSymLinks MultiViews
                AllowOverride All
        </Directory>
        ServerSignature Off
</VirtualHost>

et le répertoire dans /var/www/ est bien créer, la je sèche ...

Hors ligne

 

21/09/2009 11:56:59

Botte De Foin Publicitaire


#2 21/09/2009 13:49:31

DJo
Administrateur
Date d'inscription: 31/07/2008
Messages: 569
Site web

Re: Nouveau problème de vHosts

Pas besoin de faire un a2enmod si tu as déjà créé le vHost dans le répertoire sites-enabled/ big_smile

Le a2enmod va créer un lien symbolique du vHost dans sites-available et va le copier dans sites-enabled/

Si tu l'as déjà dans sites-enabled, restart ton apache et ça devrait fonctionner wink

Hors ligne

 

#3 21/09/2009 14:28:37

Hotfirenet
Membre
Date d'inscription: 21/09/2009
Messages: 9
Site web

Re: Nouveau problème de vHosts

j'ai fais un restart de apache mais aucun lien n'a ete creer dans sites-avaible ou je comprend pas ...
ce qui est fort possible wink

Hors ligne

 

#4 21/09/2009 14:31:16

DJo
Administrateur
Date d'inscription: 31/07/2008
Messages: 569
Site web

Re: Nouveau problème de vHosts

Oui tu comprends pas xD C'est pas grave, ça doit marcher quand même ton vHost là

Hors ligne

 

#5 21/09/2009 14:34:51

Hotfirenet
Membre
Date d'inscription: 21/09/2009
Messages: 9
Site web

Re: Nouveau problème de vHosts

pourquoi je n'ai pas cette ligne dans le fichier default ??

#RedirectMatch ^/$ /apache2-default/

le site est accessible si je fais http://192.168.0.10/hotfirenet.fr
donc c'est que ça doit fonctionner

Hors ligne

 

#6 21/09/2009 15:07:00

Hotfirenet
Membre
Date d'inscription: 21/09/2009
Messages: 9
Site web

Re: Nouveau problème de vHosts

bon je pense que ca ne fonctionne pas au niveau de apache car mon nom de domaine pointe bien sur mon serveur mais le vhosts ne doit pas etre pris en compte

exemple : http://www.hotfirenet.fr/
je tombe a la racine de apache et non sur http://82.244.182.225/hotfirenet.fr

merci de ton aide

Hors ligne

 

#7 21/09/2009 16:36:20

DJo
Administrateur
Date d'inscription: 31/07/2008
Messages: 569
Site web

Re: Nouveau problème de vHosts

Est-ce que tu as des messages d'erreurs ou warning quand tu fais un /etc/init.d/apache2 restart ?

Hors ligne

 

#8 21/09/2009 16:46:51

Hotfirenet
Membre
Date d'inscription: 21/09/2009
Messages: 9
Site web

Re: Nouveau problème de vHosts

juste

t
Restarting web server: apache2[Mon Sep 21 16:47:09 2009] [warn] NameVirtualHost *:80 has no VirtualHosts
... waiting [Mon Sep 21 16:47:10 2009] [warn] NameVirtualHost *:80 has no VirtualHosts
.

Dernière modification par Hotfirenet (21/09/2009 16:47:40)

Hors ligne

 

#9 21/09/2009 18:04:54

DJo
Administrateur
Date d'inscription: 31/07/2008
Messages: 569
Site web

Re: Nouveau problème de vHosts

Créé le fichier hotfirenetfr dans le répertoire /etc/apache2/sites-enabled/

Et test avec ce vhost:
<VirtualHost *>
        ServerAdmin hotfirenet@gmail.com
        ServerName www.hotfirenet.fr
        DocumentRoot "/var/www/hotfirenet.fr/"
        <Directory "/var/www/hotfirenet.fr/">
                Options -Indexes FollowSymLinks MultiViews
                AllowOverride All
        </Directory>
        ServerSignature Off
</VirtualHost>

Dis moi si ça change quelque chose une fois que tu as restart apache2

Si ça ne marche pas, essaye en supprimant le . de ton répertoire web, mais bon, je ne pense pas que cela pose problème, apache te l'aurais signalé.

Hors ligne

 

#10 21/09/2009 18:29:23

Hotfirenet
Membre
Date d'inscription: 21/09/2009
Messages: 9
Site web

Re: Nouveau problème de vHosts

alors avec le vhosts que tu m'a filé ça ne fonctionne tjs pas ...

par contre j'ai résolu le prob avec le port 80 le message qui été plus haut en éditant dans le fichier ports.conf : la ligne #NameVirtualHost *:80
en commentaire ...

Hors ligne

 

#11 21/09/2009 18:40:41

Hotfirenet
Membre
Date d'inscription: 21/09/2009
Messages: 9
Site web

Re: Nouveau problème de vHosts

tu vois ce qui est bizarre c que je ne trouve pas la ligne que tu dit qu'il faut commenter ...

#RedirectMatch ^/$ /apache2-default/

elle n'est pas presente dans le fichier defaut .... je comprend pas

Hors ligne

 

#12 22/09/2009 14:13:11

Hotfirenet
Membre
Date d'inscription: 21/09/2009
Messages: 9
Site web

Re: Nouveau problème de vHosts

et je peux meme pas demander sur le dorum de debian france, il est inaccessible ..

Hors ligne

 

#13 22/09/2009 16:06:12

DJo
Administrateur
Date d'inscription: 31/07/2008
Messages: 569
Site web

Re: Nouveau problème de vHosts

Le problème, c'est que la dernière version de debian a changé tous les fichiers de conf, donc c'est pas top !
Ou alors c'est la MAJ des paquets.
Faudra que je prenne le temps de mettre à jour mon tuto big_smile

Hors ligne

 

Pied de page des forums

Powered by FluxBB
© Copyright 2008-2009 - LaFermeduWeb.net