La Ferme du web - Les forums

Venez baraguiner avec la communauté !

Vous n'êtes pas identifié.

#1 21/06/2009 15:36:58

knostra
Membre
Date d'inscription: 21/06/2009
Messages: 3

probleme vhost

bonjour,

Je suis en train de suivre le magnifique tuto créer un serveur web sous débian de ce forum.

Un grand merci et félicitation à celui qui l'a écrit.

Je rencontre juste un petit problème en arrivant vers la fin de l'installation d'apache, il est dit de taper cette commande:

Code:

root [/etc/apache2/sites-available] > nano /etc/apache2/sites-available/000-default

et de commenter la ligne suivante:

#RedirectMatch ^/$ /apache2-default/

le problème c'est que je n'ai pas de fichier 000-default dans le dossier concerné, j'ai juste le fichier que j'ai créer comme c'est indiquer plus haut dans le tuto, j'ai un fichier "default" et un autre "default-ssh"

j'ai donc supposé que c'était le fichier "default" qu'il fallais modifier pour mon cas mais je trouve aucune ligne RedirectMatch dedans donc impossible de terminer correctement la configuration d'apache!

d'ou ma demande d'aide!

merci

Hors ligne

 

21/06/2009 15:36:58

Botte De Foin Publicitaire


#2 21/06/2009 15:40:22

DJo
Administrateur
Date d'inscription: 31/07/2008
Messages: 569
Site web

Re: probleme vhost

Sous quelle distribution est-ce que tu tourne ?
SI tu ne l'as pas c'est pas grave, essaye de voir si ton domaine pointe où il faut et ça sera bon smile

Hors ligne

 

#3 21/06/2009 16:02:03

knostra
Membre
Date d'inscription: 21/06/2009
Messages: 3

Re: probleme vhost

debian lenny 5.0 je crois pour la distribution.

si tu veut mon nom de domaine dynDns redirige bien sur mon serveur ça c'est ok par contre j'ai toujours le message "it's Work" et non pas "Bienvenue sur mon nouveau site!"

c'est ça mon problème en faite.

ce qui veut dire si j'ai bien suivi le tuto que apache redirige vers la page défault "it's Work" et non pas vers la page que j'ai créer et ou j'ai mis "Bienvenue sur mon nouveau site!" et si je ne trouve pas le fichier qui fais la redirection comment faire pour afficher ma page créé?

encore merci pour ton excellent travail j'ai vu qu'il y as encore plein de tuto que je vais suivre, ce que j'aime bien c'est la présentation et la facilité de compréhension c'est pratique pour les newby comme moi.

le graphisme du site est super aussi (les couleurs big_smile )

Hors ligne

 

#4 21/06/2009 17:16:48

knostra
Membre
Date d'inscription: 21/06/2009
Messages: 3

Re: probleme vhost

donc après vérification le problème est bien là !

Le nom de domaine point vers /var/www/index.html

alors que moi je veux qu'il soit redirigé vers /var/www/mon_site/index.html

mais je ne trouve pas ou faire la modif.

un peu d'aide serais le bienvenue.

Hors ligne

 

#5 21/06/2009 19:03:05

DJo
Administrateur
Date d'inscription: 31/07/2008
Messages: 569
Site web

Re: probleme vhost

Est-ce que tu as fait ton fichier vHost avec le bon chemin ? (Copie colle le ici)

Est-ce que tu as bien reboot apache2 ?
-> /etc/init.d/apache2 restart

Hors ligne

 

#6 09/07/2009 22:52:32

foxdie
Membre
Date d'inscription: 09/07/2009
Messages: 1

Re: probleme vhost

Salut, j'ai exactement le meme probleme que knostra donc je relance, pas de fichier 000-default, seulement un fichier default, et dans celui-ci aucune ligne :"RedirectMatch ^/$ /apache2-default/" ou quoi que se soit qui ressemble. Et donc, quand je tente d'acceder a mon domaine par internet, je me retrouve dans /var/www/ et non pas dans /var/www/MONDOMAINE.

<VirtualHost *>
        ServerAdmin MONMAIL@gmail.com
        ServerName www.MONDOMAINE.no-ip.fr
        ServerAlias *.MONDOMAINE.no-ip.fr
        DocumentRoot /var/www/MONDOMAINE/
        <Directory /var/www/MONDOMAINE/>
                Options -Indexes FollowSymLinks MultiViews
                AllowOverride All
        </Directory>
        ServerSignature Off
</VirtualHost>

Dernière modification par foxdie (10/07/2009 11:21:27)

Hors ligne

 

Pied de page des forums

Powered by FluxBB
© Copyright 2008-2009 - LaFermeduWeb.net