La Ferme du web - Les forums

Venez baraguiner avec la communauté !

Vous n'êtes pas identifié.

#1 12/05/2009 00:26:21

Infinito
Membre
Date d'inscription: 08/05/2009
Messages: 14

pb Apache2 Debian5 alias et vhosts qui ne s'afichent pas tous!

Bonjour,
je suis bien embêté car depuis quelques jours je n'arrives plus à afficher plus d'un vhost alors que j'ai vérifié et revérifié les configurations, j'ai même ajouté la ligne type "Alias /phpmw /home/usercourrant/phpmv" mais je n'en n'ai qu'un qui s'affiche, j'aimerai faire en plus de mon dossier root un dossier pour le phpmyvisites, en dehors et un dossier pour y installer un forum et puis d'autres dossiers du genre qui seront en dehors du dossier root mais qui devront afficher le contenu quand l'adresse du site sera complété d'un slash et du nom de l'alias. J'ai essayé avec les vHosts et les Alias mais plus rien ne veux avancer et rien ne s'affiche dans ces dossiers concernés juste erreur 403 comme si je n'avais pas les droits d'y accéder mais pas 404, deplus si je change le chmod du dossier en 777 eh bien je ne peux plus accéder au contenu du dossier avec l'explorateur ou le ftp... dites moi que puisje faire !! je viens de penser à quelque chose, à confirmer avant d'essayer : changer le chmod du dossier et donc donner l'accès aux utilisateurs faisant partie du groupe dont l'id sera 777 ..... mais à confirmer car dans ce domaine je tâtonne encore!

Merci de m'avoir lu jusqu'au bout, en espérant que quelqu'un pourra me répondre et me donner une solution.

Au fait j'ai déjà fouillé la doc d'apache 2.2 à ce sujet mais rien ne donne l'objectif escompté je reste au même point. sad

Hors ligne

 

12/05/2009 00:26:21

Botte De Foin Publicitaire


#2 12/05/2009 09:15:49

DJo
Administrateur
Date d'inscription: 31/07/2008
Messages: 569
Site web

Re: pb Apache2 Debian5 alias et vhosts qui ne s'afichent pas tous!

Question à deux euros: T'as reboot apache2 ? apache2 -k restart ?

SI c'est le cas, est-ce que tu peux copier coller tes vHosts.

Je comprends pas tout ton problème là ... tu mélange vHosts et répertoires systèmes, droits ... Quel est concrètement ton problème ? Et qu'est ce que tu veux faire ?

Hors ligne

 

#3 13/05/2009 20:18:07

Infinito
Membre
Date d'inscription: 08/05/2009
Messages: 14

Re: pb Apache2 Debian5 alias et vhosts qui ne s'afichent pas tous!

re,

Biensur que j'ai redémarré apache et même le systeme complet, plusieurs fois ! Tan pis pour tes deux euros ! ;-D

Pour les vHosts tu veux que je t'en copie un, c'est ça ? Car j'ai pris le même model j'ai juste enregistré sous un autre nom. je t'en mets deux comme ça tu vois par toi même ok ?

Le premier vHost (qui marche!)

Code:

<VirtualHost *>
        ServerAdmin MON_EMAIL
        ServerName XXXXXXX.org
        ServerAlias *.XXXXXXX.org
        DocumentRoot /home/DOSSIER_PERSONNEL/XXXXXXX.org/
        <Directory /home/DOSSIER_PERSONNEL/XXXXXXX.org/>
                Options -Indexes FollowSymLinks MultiViews
                AllowOverride All
        </Directory>
        ServerSignature Off
</VirtualHost>

Le second vHost (qui me marque erreur 403)

Code:

<VirtualHost *>
        ServerAdmin MON_EMAIL
        ServerName XXXXXXX.org
        ServerAlias *.phpmv
        DocumentRoot /home/DOSSIER_PERSONNEL/phpmv/
        <Directory /home/DOSSIER_PERSONNEL/phpmv/>
                Options -Indexes FollowSymLinks MultiViews
                AllowOverride All
        </Directory>
        ServerSignature Off
</VirtualHost>

Maintenant le fichier apache2.conf enfin l'extrait qui n'en fait marcher que deux sur toute la liste...

Code:

Alias /r&c /home/DOSSIER_PERSONNEL/r&c
Alias /www /home/DOSSIER_PERSONNEL/www
Alias /erreur /home/DOSSIER_PERSONNEL/erreur
Alias /forum /home/DOSSIER_PERSONNEL/forum

Voilà et sur cette partie de code seuls le dossier "erreur" et le dossier "r&c" sont accessibles et affichent leur contenu, les autres "www" et "forum" m'affichent erreur 403. Je tiens à préciser que je n'ai aucun dossier à la racine de mon site qui porte le même nom que ceux cités dans les alias et les vHosts.

Je souhaites juste pouvoir avoir 2 sites en plus du principal ainsi qu'un dossier pour phpMyVisites et un pour un forum phpbb mais tous ces dossiers à coté du premier car lors de dévelopement avec plusieurs colaborateurs je ne souhaites qu'avec le ftp ils puissent parcourir les dossiers des autres sites sans pour autant être limités dans les droits d'acces. Si je n'ai pas été asses clair, dites le moi et je ré-explique.

J'espère que vous allez me trouver une bonne solution!


PS : je tiens à préciser que pour les vhosts si je n'avait pas rebooté apache je n'aurait pas une erreur 403 mais plutot 404 car le fichier serait introuvable.

Au fait, j'utilises putty pour le SSH et jaimerai bien savoir comment copier le contenu des fichiers que j'édites à l'aide du ssh, car pour le moment j'ai juste fait une copie dans un dossier accessible par ftp. puis rapatriment par ftp. merci.

Hors ligne

 

#4 15/05/2009 12:48:03

Infinito
Membre
Date d'inscription: 08/05/2009
Messages: 14

Re: pb Apache2 Debian5 alias et vhosts qui ne s'afichent pas tous!

Dommage que plus personne ne me répondes....   sad

Hors ligne

 

#5 15/05/2009 12:57:32

DJo
Administrateur
Date d'inscription: 31/07/2008
Messages: 569
Site web

Re: pb Apache2 Debian5 alias et vhosts qui ne s'afichent pas tous!

Ca ne viendrait pas plutôt de tes scripts ?

Essaye de supprimer le contenu de tes répertoires, et met y seulement un fichier index.html avec un "Hello world" pour voir si les alias fonctionnent.

Hors ligne

 

#6 17/05/2009 14:12:10

Infinito
Membre
Date d'inscription: 08/05/2009
Messages: 14

Re: pb Apache2 Debian5 alias et vhosts qui ne s'afichent pas tous!

c'est ce que j'ai deja essayé et le probleme est le meme j'ai des 403......

Hors ligne

 

#7 20/05/2009 12:23:50

Infinito
Membre
Date d'inscription: 08/05/2009
Messages: 14

Re: pb Apache2 Debian5 alias et vhosts qui ne s'afichent pas tous!

Bin, merci pour votre aide,

Je me suis démerdé encore une foi tout seul,

Plus la peine de chercher à nouveau j'ai réglé le pb : j'ai viré les vHosts et tout remis a l'aide de la commande Alias /dossier /pointdemontage/dudossier


Pour toute question, vous pouvez me contacter.


Bonne journée à tous!

Infinito_

Dernière modification par Infinito (06/09/2009 17:20:28)

Hors ligne

 

#8 20/05/2009 21:15:29

DJo
Administrateur
Date d'inscription: 31/07/2008
Messages: 569
Site web

Re: pb Apache2 Debian5 alias et vhosts qui ne s'afichent pas tous!

Ben pourquoi tu l'explique pas directement ici pour en faire profiter les autres qui sont dans ton cas ?

Tant mieux si tu as réussi !

Hors ligne

 

#9 06/09/2009 17:23:02

Infinito
Membre
Date d'inscription: 08/05/2009
Messages: 14

Re: pb Apache2 Debian5 alias et vhosts qui ne s'afichent pas tous!

cc,

trop compliqué à expliquer, jsuis pas très bon pour ça mais j'ai quand même donné le truc qui m'a réglé mon problème, donc avec un peu de recherche personnelle on arrives à un résultat qui fonctionnes  comme on le désires.

Enfin j'ai un peu l'impression que c'est mort ici.... dommage....

Hors ligne

 

Pied de page des forums

Powered by FluxBB
© Copyright 2008-2009 - LaFermeduWeb.net