La Ferme du web - Les forums

Venez baraguiner avec la communauté !

Vous n'êtes pas identifié.

#1 19/04/2009 19:58:08

manolinis
Membre
Date d'inscription: 19/04/2009
Messages: 6
Site web

Apache2 +deb lenny +dedibox => apache2: bad user name ${APACHE_RUN

Bonjour,
Je suis sur dedibox - Debian Lenny.
J'ai suivi, avec plusieur tentatives la procédure d'installation. J'étais parti sur du "how to" avec ISPCONFIG, finalement je préfère ta config.
Cependant, je reste bloqué sur cette étape:

4) Reboot du serveur web

Pour qu'apache prenne en compte ces modifications, nous rebootons le serveur web:

Code:

root [/var/www/] > apache2 -k restart

Si tout s'est correctement déroulé, vous ne devriez avoir aucuns messages et votre serveur web devrait toujours être accessible.

J'ai bien respecté:

Code:

root [/var/www] > a2enmod userdir

mais quand je valide le redemarage du service

Code:

root [/var/www/] > apache2 -k restart

, et là, c'est le drame:
j'ai le message:

Code:

apache2: bad user name ${APACHE_RUN_USER}

Je tiens à précisé que sur ma console dédibox, mon nom de domaine est bien enregistré.
Mon reverse dns est sd-XXXXX.dedibox.fr où "sd-XXXXX" est mon hostname.
Sans modifier ses inormation, j'ai déjà pu par le passé accéder à mon nom de domaine via ISPCONFIG.

Voulant aller plus loin, j'ai constinué les étapes de l'installation. J'ai crée mon vhost, et effectivement j'accede à mon domaine via

Code:

http://monip/mon_dossier_domaine

ainsi que via

Code:

http://www.mondomaine.com/mon_dossier_domaine

Si je tente simplement

Code:

http://www.mondomaine.com

je tombe sur la page par défaut d'apache2

Hors, je n'ai pas de fichier "000-default"  dans /etc/apache2/sites-available!!!! et je ne peux donc pas commenter

Code:

#RedirectMatch ^/$ /apache2-default/

Dois-je faire une manipulation complémentaire?
Merci pour le coup de pouce  wink

Hors ligne

 

19/04/2009 19:58:08

Botte De Foin Publicitaire


#2 19/04/2009 20:47:05

DJo
Administrateur
Date d'inscription: 31/07/2008
Messages: 569
Site web

Re: Apache2 +deb lenny +dedibox => apache2: bad user name ${APACHE_RUN

Est-ce que tu as bien ajouté ton fichier vhost pour ton nom de domaine ?

Si oui, est-ce que tu peux me le copier ici ?

J'ai jamais eu cette erreur "apache2: bad user name ${APACHE_RUN_USER}", est-ce que tu es logué en root quand tu essaye de lancer le serveur ?

Hors ligne

 

#3 19/04/2009 21:14:14

manolinis
Membre
Date d'inscription: 19/04/2009
Messages: 6
Site web

Re: Apache2 +deb lenny +dedibox => apache2: bad user name ${APACHE_RUN

J'ajoute ceci:
je n'avais pas cette ligne "AddDefaultCharset ISO-8859-1" dans "/etc/apache2/apache2.conf" avant que je ne l'ajoute.

De plus, mon fichier "/etc/apache2/httpd.conf" était totalement vide avant l'ajout de "DirectoryIndex index.html index.htm index.xhtml index.php" et de "UserDir www"

Je suis bien logué en root (je suis newbee et j'ai déjà cette fâcheuse habitude).

Voici mon vhost:

<VirtualHost *>
        ServerAdmin webmaster@baoprod.com
        ServerName www.baoprod.com
        ServerAlias *.baoprod.com
        DocumentRoot /var/www/baoprod/
        <Directory /var/www/baoprod/>
                Options -Indexes FollowSymLinks MultiViews
                AllowOverride All
        </Directory>
        ServerSignature Off
</VirtualHost>

Et voici mon fichier "default" (pas de 000-default):

<VirtualHost *:80>
    ServerAdmin webmaster@localhost
   
    DocumentRoot /var/www/
    <Directory />
        Options FollowSymLinks
        AllowOverride None
    </Directory>
    <Directory /var/www/>
        Options Indexes FollowSymLinks MultiViews
        AllowOverride None
        Order allow,deny
        allow from all
    </Directory>

    ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
    <Directory "/usr/lib/cgi-bin">
        AllowOverride None
        Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
        Order allow,deny
        Allow from all
    </Directory>

    ErrorLog /var/log/apache2/error.log

    # Possible values include: debug, info, notice, warn, error, crit,
    # alert, emerg.
    LogLevel warn

    CustomLog /var/log/apache2/access.log combined

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

</VirtualHost>

Comme tu peux le constater, je n'ai nulle part: "#RedirectMatch ^/$ /apache2-default/"

DJo a écrit:

Est-ce que tu as bien ajouté ton fichier vhost pour ton nom de domaine ?

Si oui, est-ce que tu peux me le copier ici ?

J'ai jamais eu cette erreur "apache2: bad user name ${APACHE_RUN_USER}", est-ce que tu es logué en root quand tu essaye de lancer le serveur ?

Dernière modification par manolinis (19/04/2009 22:29:19)

Hors ligne

 

#4 20/04/2009 08:42:36

DJo
Administrateur
Date d'inscription: 31/07/2008
Messages: 569
Site web

Re: Apache2 +deb lenny +dedibox => apache2: bad user name ${APACHE_RUN

Apparemment, le serveur apache n'a pas pris en compte tes modifications, le reboot n'a pas marché.
Essaye peut être un /etc/init.d/apache2 restart ou /etc/init.d/httpd restart je ne sais plus lequel (pas de SSH sous la main)

Hors ligne

 

#5 20/04/2009 09:14:58

manolinis
Membre
Date d'inscription: 19/04/2009
Messages: 6
Site web

Re: Apache2 +deb lenny +dedibox => apache2: bad user name ${APACHE_RUN

DJo a écrit:

Apparemment, le serveur apache n'a pas pris en compte tes modifications, le reboot n'a pas marché.
Essaye peut être un /etc/init.d/apache2 restart ou /etc/init.d/httpd restart je ne sais plus lequel (pas de SSH sous la main)

Ok, je vais recommencer mon install est te tiens informé dans la soirée (voir plus tôt) si j'ai le temps de m'y mettre ce matin).

Hors ligne

 

#6 20/04/2009 23:27:33

manolinis
Membre
Date d'inscription: 19/04/2009
Messages: 6
Site web

Re: Apache2 +deb lenny +dedibox => apache2: bad user name ${APACHE_RUN

Bonsoir,
rien ne change, même avec la commande "/etc/init.d/apache2 restart".
J'ai toujours la même erreur.

Je viens de remarquer quelque chose dans le fichier "apache2.conf":

# These need to be set in /etc/apache2/envvars
User ${APACHE_RUN_USER}
Group ${APACHE_RUN_GROUP}

Et dans "/etc/apache2/envvars" j'ai:

# envvars - default environment variables for apache2ctl

# Since there is no sane way to get the parsed apache2 config in scripts, some
# settings are defined via environment variables and then used in apache2ctl,
# /etc/init.d/apache2, /etc/logrotate.d/apache2, etc.
export APACHE_RUN_USER=www-data
export APACHE_RUN_GROUP=www-data
export APACHE_PID_FILE=/var/run/apache2.pid

Et donc là.... suis bloqué !
Une (des) idée(s) ?

Hors ligne

 

#7 21/04/2009 00:37:24

DJo
Administrateur
Date d'inscription: 31/07/2008
Messages: 569
Site web

Re: Apache2 +deb lenny +dedibox => apache2: bad user name ${APACHE_RUN

Essaye directement dans ton apache2.conf de mettre:

User www-data
Group www-data

Au lieu de:

User ${APACHE_RUN_USER}
Group ${APACHE_RUN_GROUP}

Et restart big_smile

Hors ligne

 

#8 21/04/2009 18:01:31

manolinis
Membre
Date d'inscription: 19/04/2009
Messages: 6
Site web

Re: Apache2 +deb lenny +dedibox => apache2: bad user name ${APACHE_RUN

DJo a écrit:

Essaye directement dans ton apache2.conf de mettre:

User www-data
Group www-data

Au lieu de:

User ${APACHE_RUN_USER}
Group ${APACHE_RUN_GROUP}

Et restart big_smile

Bonjour,
J'ai tenté cette manipulation hier soir, grace au indication de l'ami Google.
Mais j'ai eu un autre message d'erreur.
J'ai même du ajouté dans mon fichier apache2.conf la ligne "ServerName "nomdedomaine"" (quelques chose comme ça) et rien à changé.
Je me demande si les fichiers ne sont pas quelque peu modifiés par dédibox.
Bref, je fais quelques recherches et je reviens aux nouvelles.

Hors ligne

 

#9 04/05/2009 00:27:53

manolinis
Membre
Date d'inscription: 19/04/2009
Messages: 6
Site web

Re: Apache2 +deb lenny +dedibox => apache2: bad user name ${APACHE_RUN

Hello, j'ai réglé le problème.
J'ai ajouté dans le fichier httpd.conf: ServerName localhost

Puis, dans /etc/apache2/ports.conf, j'ai commenté "NameVirtualHost xx.xx.xx.xx:80 "

Plus de message d'erreur !!!!!

Bon, cependant, je n'ai aucune ligne "RedirectMatch ^/$ /apache2-default/" à commenter, et je n'ai pas la redirection de mon site.
Voilà....

Hors ligne

 

#10 04/05/2009 08:00:11

DJo
Administrateur
Date d'inscription: 31/07/2008
Messages: 569
Site web

Re: Apache2 +deb lenny +dedibox => apache2: bad user name ${APACHE_RUN

Ok merci pour ton retour smile

Hors ligne

 

#11 05/06/2009 11:04:16

Mickael
Membre
Lieu: Tours
Date d'inscription: 16/12/2008
Messages: 1
Site web

Re: Apache2 +deb lenny +dedibox => apache2: bad user name ${APACHE_RUN

Je découvre les joies de Linux et en tant que newb complet en la matière, j'ai exactement lemême soucis smile

J'ai essayé les différentes manip' et quand je redémarre apache2, j'ai ça :

httpd not running, trying to start
(98)Adress already in use: make_sock: could not bind to adress 0.0.0.0:80
ni listening sockets available, shutting down
Unable to open logs


Edit : bon c'est good, dans mon virtualhost, il fait préciser le port 80 comme ceci :
<VirtualHost *:80>
blablabla
</VirtualHost>

Dernière modification par Mickael (05/06/2009 14:15:15)

Hors ligne

 

Pied de page des forums

Powered by FluxBB
© Copyright 2008-2009 - LaFermeduWeb.net